Conditional rules not working with "Select all" in parameter filter

Hi,

I have a parameter field converted to a drop down filter in the sheet. It lists the employees available in the dataset. On selecting a particular employee from this filter the parameter in turn also gets updated. Now I have another KPI visual which shows the selected employee’s statistics. As you can imagine when the sheet is loaded there is no employee selected and hence this KPI shows an irrelevant value. I want to show this KPI visual only when there is any employee selected in the filter

I tried to use the “conditional rules” feature available in KPI visual. But it’s not working with “Select All” option available in the filter.

save

For testing purpose, Instead of “All” I used a person from the employee list and that worked. But what I need is the above rule in the image to work

Any help would be much appreciated.

Hello @Philip , thanks for your question.

Here I understand you are using a parameter (connected to a filter) and also to a control to allow dashboard users to interact with it right?

In that case in order to achieve the expected behavior I would suggest the following actions:

  1. Configure your KPI visual to be hidden by default (as you have already done) :heavy_check_mark:
  2. Edit the parameter and make sure you set a default value for it, use a neutral value such as “-” for this (see image1)
  3. Configure your KPI visual to be shown only when parameter value doesn’t equal to “-” see image2 for more reference

Hope it helps! Happy dashboarding!

Image1:

Image2:
Image2

Hi @EnriqueS

Thanks for the detailed explanation. Unfortunately that didn’t work.

Instead of the “-” default value for parameter, I set “All Employees” as otherwise the selected value in employee dropdown will be “-” on initial sheet loading.

1

Rules

2

Now it works initially as planned. The KPI will be hidden on loading. Now on selecting a employee from the dropdown filter, the KPI shows. But as soon as I select “Select all” from the filter list to reset the dropdown the KPI doesn’t hide. If I am correct at that point the parameter is having a value of “All”. Even I tried setting the default value of the parameter as “All”. That also didn’t work.
How can we fix this problem?

FYI, The parameter “SelectedEmployee” holds a single value which is pointed to a Employee dataset. When an employee is selected by user, we check this parameter in other calculated fields for formatting purposes

In the control can you hide the select all option?

image

Hi @Max,

It’s not possible to hide the “Select all” in our scenario. We are also using the same parameter to highlight the selected employee in a vertical bar chart. The user will use the “Select all” option to reset the highlight .

If there is no other way to fix this problem, we may have to hide the “select all” option as you said. But then that means, the user will have to refresh the dashboard to get the initial view.

You can click the reset button on the control to reset it without refreshing the dashboard.

image

Hi all,

If anybody faces the same problem, this is now resolved with the new “Reserved Value” feature introduced in Parameters.

Thanks to the Team

1 Like

:rocket: :100: :slight_smile: Thank you for posting this @Philip!