Dashboard opens with data but filters show error "Request took too long. try again later"

This error happens when I open the dashboard. it works fine from the analysis.



Hi @Ali_B ,
what is the exclamation mark telling?



The data in the main table loads fine. it just the filtes.

can you try to publish with a specific element instead of “all” on the filter?

it works for a while, then users start seeing the same errors. When I first published the dashboard, it worked fine even without preselected values. then after a day or so it started showing errors

Is you dataset growing or was changed in the meantime?

The dataset is definitely growing, it is also being worked on although those filter fields are the same.

Because it seems there are to many data or the query is not performing well.

The dataset is on SPICE though. I’m not sure what the “query performance” means when your data is loaded in memory on SPICE

Ok. In case of SPICE its not relevant.

Are the filter cascading or standalone? I would try to check if i can downsize the elements in a filter and see if it will work.

@ErikG By cascading do you mean the “only show relevant values” option on filters? then they are standalone.

Hi @Ali_B
Some things to check:

  1. How many distinct values are in the fields? Is it a large number that’s causing the performance issue? Also how many rows are in the SPICE dataset.

I believe there are a few options to solve this.

  1. As @ErikG mentioned ‘only show relevant values’ will cut down the number of values returned in the filter list.

  2. Change the control to ‘Dropdown - multiselect’ so it’s not preloading every value in the dropdown.

  3. Create a dataset specifically for the filters/controls that only contains a unique list of values. Outlined here: Improve Filter performance for Direct Query Dashboards: 2023 Amazon QuickSight Learning Series