Access to a Quicksight dashboard for external consultant

I have a problem. We created two Quicksight dashboard and we want that a person from our team has an access to it. However, she is an external consultant from our organization, so how we can do? Is it something that I must check with my company IT service or with you, if you have a solution?

Thanks you a lot !


has the external consultant already access to your Quicksight? If not: Do you use the account management in Quicksight or did you connected it with an AD?
In the Quicksight account management, you can just add the the mail address of the external consultant as a user and she will get a mail and can create an account.

If you connected an external user management to your quicksight, you probably need the help of your IT.

When the external consultant has access to quicksight, you have to share the dashboard with her account.

1 Like

Hi, @Hugo_V. Welcome to the QuickSight Community! We hope @thomask 's solution worked for you. Let us know if this is resolved. (And if it is, we’d love it if you could mark his answer as a “Solution.”) Thanks!

@Hugo_V You being the owner of your QuickSight account, can manage which user should have access to any QuickSight Asset including dashboard. There are 2 ways of handling the users:

  1. Manage users through QuickSight- Here you would invite users by their email.
  2. Authenticate users to QuickSight from your iDP.

Both approaches are possible.

Thanks for your answer, however, when I wrote the mail adress of the consultant who wants the permission, Quicksight cannot see her, so I don’t know what to do at this stage. Should I contact Amazon or do something else? What could be the solution please?

Initially when you type the consultant’s email address under “Invite Users”, QuickSight will show “No Results”.

But after typing the email address, you have to click on “+” icon or hit “Enter” to add the user to your account.

Hope this helps!!

Thanks but I do not know where I could find the “Invite users” button, I’m not the owner of the account so maybe it’s that why I cannot got the access to the consultant?
Where can I find the “Invite user” button please?

@Hugo_V you would need to be an Admin on the account (when you click on your user icon in the upper right do you see 'Manage QuickSight? If not then you are not an Admin), and have appropriate IAM permissions assigned to your user. At the least you would need this permission:

But the full admin permissions would look like this:

It is also possible that when you signed up for QuickSight initially (initial account creation), you chose ‘IAM federated identities only’ or ‘Active Directory’ and not ‘IAM federated identities and QuickSight-managed users’. If you submit a support ticket with your account ID information, they can turn on the QuickSight-managed users (aka email users) after the fact.