Anomaly detection alerting on previous periods

I have a dashboard tracking daily transactions on a cybersecurity monitoring platform.
The data is imported in a daily process that is scheduled to run each day in the early morning, and as a result, the data for “today” is always partial.
Since I want to track and compare only days with full data, I’ve set all the end-date on all visuals to “yesterday”.
I’ve applied the same end-date also to the anomaly detection visuals (otherwise, they recognize the partial data as a drop in transactions every day); however, it seems like alerts are not triggered this way.
I see visuals presenting anomalies from yesterday, yet no alert was fired.
I tried checking the “Set alert past period” option to 1, but it seems to be turned off every time I enter “configure alert” after saving.

Any suggestions - on how to set the anomaly alerts to be triggered for yesterday’s data?

Hello Yuval, sorry i can’t get your question clearly. Since you’ve had the anomaly detection visuals, can you create the alert right from the cell of your detection result? That means, right click the cell that shows the anomaly detection result, then choose create alert.

Hi @Sophia ,
I configured the alert on the anomaly detection visual while configuring the dashboard as an author

I now see that there is also an option to configure the alert on the dashboard

maybe this is what I was missing

Yes please try to configure the alert from detection result. Please let us know if it resolved your problem.

Thanks, @Sophia - that seems to have solved the problem.
All alerts are triggered as expected now.