Ask a question from Q that contain value

I have a topic that has 2 fields called name and country. I asked Q the following question:
What are names for country USA? but it return an error like below:
I know I have data for country USA.
What’s the reason?

@Noorali can’t see the error properly.
Q is not as smart as you think, if you have an option, try changing a column name of name to something else and try rephrasing your question accordingly, see if that works.

Also, map that column with synonyms.

Thanks @neelay for the reply.
For instance, I have product name field in my topic and I ask all product names but it doesn’t show anything. I tried to refresh dataset and add synonyms but it didn’t work.

tagging @Kristin, so she can share this with the product team.

Hi all. I have shared this with our on call SA and one of the PMs.

Hi @Noorali,

Most likely root cause is that you have Row Level Security applied on base dataset and your user don’t have permission to the USA records.
I was able to get the results on a sample at my end when I gave myself access to USA and got the same error as you encountered when I blocked my access to USA records. (See below).

If this isn’t the case at your end, I would recommend filing a case with AWS Support where we can dive into the details so that we can help you further. Here are the steps to open a support case. If your company has someone who manages your AWS account, you might not have direct access to AWS Support and will need to raise an internal ticket to your IT team or whomever manages your AWS account. They should be able to open an AWS Support case on your behalf. Hope this helps!

Arun Santhosh
Pr QuickSight SA

1 Like

Thank you @ArunSanthosh! :slight_smile:

And thanks for the ping @neelay!