Auto-discoverd of Redshift is not working and I can't create a dataset.

The Auto-discovered feature of Redshift is not working, leaving me unable to create a dataset. As shown in the attached image, the error message ‘No available instances in this region for this account’ appears during the dataset creation process. Both Redshift and QuickSight are properly located within the same VPC, and the security group settings are also functioning well. The

connection is showing as available. IAM is checked for Redshift and the settings to allow automatic discovery on the Redshift side are enabled, so I cannot understand the cause of this issue. I am looking for a way to resolve this problem. Thank you for your assistance.

Hi @YellSub ,

The screenshot shows that the Connection Type is ‘Public Network’, but you also note that, “…Redshift and QuickSight are properly located within the same VPC”.

I’m assuming that Redshift is marked as ‘Not Publicly accessible’, which means that the drop down should be from your Quicksight VPC Connections, namely the Redshift VPC Connection.

Can you confirm that you’ve setup a VPC Connection in the ‘Manage VPC Connections’ page in Quicksight and that the status is ‘Available’.

If so, then you’ll be able to simply select that VPC connection in the drop down and your Redshift Instance should show up.

If not, then you’ll have to setup up a connection by following the post here.

Hope that helps. Let me know if that doesn’t work.


1 Like

Thank you for answering.
We have confirmed that Manage VPC Connections is available.
Redshift public access is set to on.
And when selecting the instance ID in the pull-down menu, the instance ID does not appear and it looks like the image. I have checked the VPC instructions you pointed to several times and built the VPC as instructed, but the situation does not improve. thank you.

Thanks @YellSub ! Got it.

There’s a couple other things to verify:

  1. Confirm that the Quicksight region is the same region that Redshift is available in:
    Screenshot 2023-11-22 at 8.30.45 AM

  2. Confirm that Redshift is turned on in your security settings:

If this doesn’t solve the issue, the next step is to open a support ticket and ask them to look into your Quicksight instance to resolve this.

Hope that helps.