Dataset changed too much for Quicksight to automatically update your analysis

I am unable to use quicksight dashboard (trying to read data/ look at dashboards etc) while other team members who have access to dashboard can use it just fine. I see a red exclamation mark with a “refresh” button. I also see the message “The dataset changed too much for Quicksight to automatically update your analysis. You can edit the fields or filters in the current dataset or replace it with a different dataset.”

I have tried using this on different browsers, and also tried to clear the cache.


This may help you.

Naveed Ali

do you mean that other team members do not the see this error when they access the same analysis?
if they don’t have problem in the same analysis, one of the reason can be some script was blocked by the browser. As you have tried different browser already, I would suggest to raise a support ticket. Backend engineers can check the log in backend and they can even do a screen sharing with you and monitor the error logs in real time

When I pressed the “reset filters” on the top left - it started working for me. Sorry I just didn’t realize it was a simple problem.


Thank you for letting us know @Stuti_Jain! And glad everything is working for you now. :slight_smile: