Dataset Replacement failing

I’ve cloned an analysis and wish to swap the underlying datasets to new data sources. The replacement datasets are exact matches for the current datasets in the analysis. I’ve triple checked and every field definition is identical in spice. Each time I choose “Replace” inside the analysis I get the error: Something went wrong while validating the dataset replacement. Contact AWS Support to resolve this issue.
This happens even if I duplicate the existing dataset used in the analysis and then try to switch to the duplicate. It’s also the error I get if I try to replace with a completely different dataset (i.e. different fields, etc.) which should generate a totally different error. I have 100GB of available SPICE storage.
I don’t have an AWS Support contract, so I thought I’d check with the community to see if anyone knows the solution.

HI @aswilson ,
Thanks for your question. Is this a SPICE dataset or live query? Has there been changes made to the data source? Is it possible to refresh the dataset, then duplicate it to replace to the new one? Is there row level security applied? Are there more than one dataset used in the Analysis?

1 Like

There are 10 SPICE datasets in the analysis. One from an S3 source, the rest from upload files. All fail with same error.
No changes to the incumbent datasources. The replacements are new, but they are verified for data field types, sequence and count.
There is neither row level security nor special permissions applied.
We did replicate one of the current datasets and tried to use it as a replacement (with no data update) but that also failed with the same error.
It seems the analysis (and it’s copies) are in some borked state where they will not accept any replacement dataset.

I’ve been experiencing the same issue since a few hours ago when I wanted to replace a dataset in an analysis that’s behind a live dashboard. The dataset is also a copy of the existing one, except for 2-3 extra columns.
I noticed that Quicksight won’t let me replace any dataset in the analysis, regardless of my choices. Nothing changed recently in the analysis.

Also, I duplicated the analysis hoping the issue would leave, but it remained there.
Notice that when I try to do the same operation in other analysis the issue is not there.

PS: this is an usual practice for me and it is not the same time I replace a dataset in the same analysis.

I am experiencing the same issue:

Do you happen to have any controls (pinned to top or on-sheet) that reference deleted entities such as a parameter control where the parameter is no long present? If so, can you try deleting or repairing that control and then retrying the dataset replacement?


Yep. That was the issue for me. I wouldn’t have suspected one broken parameter control would cause that error message on a data replacement for a dataset that wasn’t involved in driving the parameter or the control values. Very obscure. Thank you for solving @blakecar !


Thank you! Solved the issue for me as well.
Error messages could be more expressive!


Hi everyone,

I am experiencing the same issue but I don’t have any parameters / controls in my analysis.

When I try to replace my dataset with another dataset (same format), it gives me this same error:

Something went wrong while validating the dataset replacement. Contact AWS Support to resolve this issue.

I double checked that there is no parameter / control issue, and the formats of the datasets are the same. The only thing I could imagine that the reason is something with calculated fields, but I added all the calculated fields at the analysis level, so it should easily re-route the calculations to the replaced dataset.

I would appreciate an explanation / workaround :slight_smile:


It’s possible you’re seeing a separate issue.

Just to clarify in case this helps though - the controls also includes filters that are either pinned to the the top of the sheet or in the sheet layout itself. The known issue above happened when one of those controls was referencing a deleted parameter or filter. They’re somewhat distinct looking elements in case you did have one of those.

Hi again @blakecar @bergqdou,

I thought I checked thoroughly enough but I found a hidden control in one of the tabs, however, it was associated with a field from another table. Issue solved, but just a question: why does this data replacement fail even if the reason has nothing do to with the relevant datasets?

It shouldn’t be a blocking issue. The service team has a fix in the pipeline that should prevent the need to perform that clean-up soon.

1 Like

I am experiencing such issue as well. Trying to replace a direct query to Athena with a SPICE dataset. Exactly the same schema. Tried the following:

  1. Changed the query to use exactly the same data under the SPICE, and replace.
  2. Change the Direct Query to SPICE, and replace SPICE with another same SPICE.
  3. try the above with a copy of the Analysis

All failed.
The error message is not helpful. And we cannot redo the whole analysis with a different dataset, coz it’s too much work!

It turned out to be a broken control in one of tabs. So same issue as people seeing here.

Hello @daweiz, welcome to the Quicksight community!

Could you repost your question as a new topic at the top of the community? You can link back to this topic as well.

This way your question is prioritized by our Quicksight experts and is not within a closed topic.