Date format changed to yyyy-MM-dd when queryng data from database

I connected a dataset to my database . I specified in dataset editor the fields that are dates and that the format should be dd/MM/yyyy. QS accepts the format but converts all fields to yyyy/MM/dd HH:mm:ss .
The issue is that when I then use parameters in subtitles the date format is wrong and shows yyyy/MM/dd instead of the original dd/MM/yyyy.
I don’t understand what I’m doing wrong and why QS changes my date format when queryng the database.
In data prep it even tells me before that the date will be displayed as dd/MM/yyyy but when I then select update nothing happens and all the fields are still yyyy/MM/dd.
Any help welcome,
Domenico

hi @Dom - we’ll try to reproduce the issue on our end. Can you share what database you’re using and are you using direct query or SPICE in QuickSight? thanks!

Hi
I’m using MySQL RDS database qith direct query.

Thank you.

Thanks Dom, I reached out to our engineering team about this issue you’re experiencing. I’ll get back to you when I have an update.

can you please clarify on below questions,

  1. When using MySQL RDS with any column as date type, it should auto detect and set default date format. It will be yyyy/MM/dd HH:mm:ss. did it not inferred that column type as date?
  2. in dataset the date format cannot be set, at-least not available currently whereas can set the format in analysis. isn’t that not working when set the date format only in analysis?
    Note: we only support setting date format in dataset for file data sources.

Thanks I think this is the limitation I encountered so when I link a parameter in my Visualization Title the date is displayed in the default date format. Instead in my filter bar I have the option to change the date format.