Default currency format

Is it possible to set a default currency format?

It’s quite tedious to set it for all fields in a pivot table.


HEllo @BFJonk ,
If you change it at field level it will always apply the same currency in all visuals:



That’s awesome!
Thank you so much, José.

Still, I think it would be useful to be able to tell QuickSight we work in EUR not $, for all Currencies.



@JoseB-aws This is helpful to know. Does it work for other numeric data as well?

As of today 31. Mar 2023 you can :slight_smile:

You mean :


Where do you specify that?

Hi Bart,

you can specify it in the field settings:

  1. Choose “Show as: Currency
  2. Then “Format: €1,234.57 Euro

You still have to do it field by field, but at least you doit on the field level on on every visual.


Thanks @Gabriel_R for posting this! :slight_smile:

@BFJonk did Gabriel’s reply provide the solution you needed? Hope so! If so, could you help the community out by marking that reply as “Solution” (clicking the check box under the reply)? Thanks!

Hi Kristin,

Did so. However, I might miss it, but to me the solution of Gabriel_R seems to to be the same as the one from JoseB-aws.

(And still, I think it would be useful to be able to tell QuickSight we work in EUR not $, for all Currencies).

Hi @BFJonk, @JoseB-aws JoseB-aws’s here is the current way of doing this (however, it has to be done for each individual field).

The option to adjust the default formatting settings has been tagged a feature request.

Hi Kristin,

That’s nice. Yesterday I noticed the same goes for Time Formats (over here, across the pond, we’re not used to AM/PM and prefer 24H as the standard).

Hope that has been included!


1 Like

Thanks for calling this out @BFJonk.

Same request here. It would be interesting to add localisation parameters to modify the default behaviour of currencies and dates. For instance, in Spain (I think this applies to most Europe), we use commas for decimal separators and points for thousands.