Describe_data_set_refresh_properties error


I need help calling describe_data_set_refresh_properties from my lambda function. I get this error when trying to call describe_data_set_refresh_properties method in my python 3.9 code. All posts with this error were resolved with updating boto3 to newest version. This is what I did and it’s not working.

This is my code (shortened for brevity)

import botocore
import boto3

client = boto3.client(‘quicksight’)
DataSetId_in = ‘yyyyy’

client.describe_data_set_refresh_properties(AwsAccountId=AwsAccountId_in , DataSetId=DataSetId_in)

Error message: ‘QuickSight’ object has no attribute ‘describe_data_set_refresh_properties’

I also call describe_data_set, list_data_sets, create_ingestion… and all of these work fine.

And I have same Boto3 version as in documentation: describe_data_set_refresh_properties - Boto3 1.28.68 documentation

Lambda function uses python 3.9 version.

$ python3 -c “import boto3, sys; print(f’{sys.version} \nboto3: {boto3.version}')”
3.7.16 (default, Aug 30 2023, 20:37:53)
[GCC 7.3.1 20180712 (Red Hat 7.3.1-15)]
boto3: 1.28.68

Is there anything else that should be updated or checked?

Hi @Natasa - This looks good to me, can you try to pass the region name while defining the quicksight client. if the problem still persists, please raise a ticket to AWS customer support team to check it. To raise the ticket, please follow the link - Creating support cases and case management - AWS Support

hi @ErikG @duncan - Any expert advise on this?

Regards - Sanjeeb

I had the same issue with “describe_analysis_definition” at the beginning. I use a local python env. and had to update the CLI version and python as well.

Thanks @ErikG .

Hi @Natasa - Is it possible to try with Python 3.8 version. Give a try.

Regards - Sanjeeb

I have tried python 3.8 as well as passing a region in client definition and none of it worked. Same error message as before.

@ErikG could you please provide steps, so that I can check if I updated everything there is?


@Natasa i dont know all steps but i used e.g. for the update

Get started with the AWS CLI - AWS Command Line Interface (

1 Like

Resolved it by moving to Python 3.11! Boto3 update probably helped but this last step fixed it.

It would save a lot of time if we would be able to see version prerequisites somewhere in the documentation.

Thanks for your help!


Thanks @Natasa . Ideally we should upgrade the version, my bad i requested for downgrade it. Thanks for sharing the solution.

Regards - Sanjeeb

1 Like