Direct Query with Parameters Timeout

I am trying to implement a Direct Query with parameters to report row comparison metrics in Quicksight. I am using amazonbi.

Currently, the query runs locally in Datagrip in 30s-1m querying Redshift tables. However, consistently times out in Quicksight during normal working hours. Tables are optimized for performance. If Direct Query could work consistently, we could implement a dashboard to take user input compute comparison. It is infeasible to have a SPICE dataset to compare each record in table with other records, and Quicksight calculated fields do not enable metrics to be computed at the desired granularity.

Is there a way to increase the timeout within Quicksight? Currently about 2 minutes - could we extend this to 5 or 10 minutes? Is there a way to optimize the performance of the Direct Query in Quicksight so that it completes consistently in 2 minutes?

Why does the query keep timing out in Quicksight? How can I fix this?

Goal: implement direct query in QS so it works quickly and consistently. Not just a quick fix that works some of the time.

Hi @julvanp - Welcome to AWS QuickSight community and thanks for posting the question. You are correct, the timeout parameter for direct query is set to 2 mins and any query running more than 2 mins is definitely a performance concern for QuickSight. We need to understand the and optimize the query . From Redshift side, can you tune the sql and explore the WLM feature ( See the link - Workload management - Amazon Redshift). You can create different queues and give some priority to your QuickSight queries. Also check the table stats, number of rows or any filter you can put so that you can bring the right data set for reporting.

I am also tagging other quicksight experts for their advise as well.
Hi @eperts @David_Wong @Naveed @Koushik_Muthanna @ArunSanthosh - Kindly give your opinion on this?

Regards - Sanjeeb

1 Like

Hi @Sanjeeb2022 , I have the same issue. We are tuning Redshift but in the meantime we need to increase the timeout from 2 to 5 min. Could you help us to increase it?
Many thanks,

1 Like

Hi @amanrique - Welcome to AWS QuickSight community and thanks for posting the question. Unfortunately we can not increase the timeout parameter from 2 to 5 Mins. However we can request this as a feature request to QuickSight team to put this as a road map.

Tagging some of the experts for their advise.
@eperts @Koushik_Muthanna @Max - Please provide your feedback on this?

Regards - Sanjeeb

Hi @julvanp - The problem is more data model related than Quicksight. Please check the following :

  • You may also have to tune your Redshift cluster as Sanjeeb pointed out.
  • check the access patterns at the Redshift level. if there are other workloads querying Redshift it may have an impact on performance and make the dashboards slow. Essentially, having multiple use cases running against the same cluster and competing for resources can have an impact.
  • If you can’t achieve query performance below 2mins then I would recommend re-factoring the data schema so that it performs better.

In regards to the 2min timeout I can see the QuickSight arguing that even with the current timeout having a user wait for two minutes for a dashboard is already bad user experience, let alone increasing to 5mins. I ll tag this post as a feature request though.

1 Like