Edit, Remove or Substitute Dataset on Analysis

I am not being able to Edit, Remove or Substitute any of the Datasets on one of my Analysis. The only option is to add new datasets.

I have checked the analysis permissions through describe_analysis_permissions and it is exactly the same as other analysis in which I can change it. Also, tried to create a template and re-create another analysis from that template and I’m still not able to change it’s datasets. Is there anything I can do to resolve it?
I need to replace the datasets on this specific analysis in order not to re-create its calculated fields, visuals, etc… all over again.

Hi Mauricio - sounds like you are aware of the Replace Data Set feature, but you aren’t seeing that option? Can you maybe include a screenshot?

That’s it. It seems it is missing horizontal scroll bar, maybe:



please check this Vedio. this will help you

Interesting, seems like a bug on the window sizing. In the meantime can you maybe try zooming out on your browser to see if it shows up? In parallel we can open a ticket to get this looked at.


Thanks for the video! You nailed exactly how to replace a data set but appears Mauricio doesnt see the ‘…’ menu to trigger it. Ill have the product team look at it.


Thanks for the response! You nailed it. If I change resolution and zoom in (i’m not sure why zooming in and not out works),it gives me the option.

Good! Glad that works for now. Thanks for raising this. I’ve started conversations with the product team to fix this behavior.