Error during analysis update from cli with inputting modified JSON

Hi all,

For the first time I use Quicksight API’s to copy a sheet from an analysis and pasting it to another analysis. For both analyses I do:

  1. aws quicksight describe-analysis-definition --aws-account-id --analysis-id /home/br_stage.json
  2. Then I modify the “Definition” section in the .json to include the new dataset from 1st analysis. I add the new sheet and filters from 1st json of analysis to the other json of the analysis to update.
  3. I run aws quicksight update-analysis --aws-account-id --analysis-id --region eu-central-1 --cli-input-json file:////home/bright_stage_analysis.json

I then get the following error which did not find any information about:
An error occurred (InvalidParameterValueException) when calling the UpdateAnalysis operation: Filter must define only one of Numeric Value or Parameter Name, **
** at Filter

Anyone has an idea what could go wrong?


Hello @Fotis_flex, my initial thought is it may be an issue with a duplicate parameter name/value in the sheet that you pasted into the analysis. This could possibly cause an error to occur. I also found another topic in the community related to the issue you are having. I will link that here in case there might be useful information for you.

Let me know if that helps or if you find any new information in your debugging process!

Hello @Fotis_flex, did my response help you resolve your issue in QuickSight? If so, feel free to mark it as a solution. If not, please follow-up with some more details about the issue you are facing and I can try to guide you toward a solution. Thank you!

Hallo @DylanM , Unfortunately I haven’t managed to do much of progress on troubleshooting. I still get this error on the filters section which I cannot explain. I checked for duplicated variables but there are not any! I am new to attempting programmaticall updates on analysis/dashboards and I have no clue what might go wrong

1 Like

Hello @Fotis_flex, keep me updated on the errors you experiencing and we can try to debug it together. It definitely is a confusing issue,

Hi @DylanM and thanks for offering your help. It seems that the error was caused by a filter defined as non equal to but without providing an actual value inside the analysis! It’s solved now. However, I fell into another issue. I try to update an analysis that resides in a region different from the one I use to update it. My problem here is that in the .json analysis definition, the themeARN definition contains the region and account that are different from the analysis I try to update. My wonder is how can I make this themeARN universal? Is there any option for this? Thanks!

1 Like

Hello @Fotis_flex, my apologies for the delayed response to your last message. In order to ensure a more optimal response time and also to give your follow-up question it’s own topic because I think it could be really benefitial to the community, do you mind posted a new question in the community? Or if you were able to resolve it, even posting that solution so we can archive it to help other QuickSight users with the same problem.

For now, I’ll mark your last response as the solution since you were able to fix the initial problem you were facing. Thank you!