Error: "We weren’t able to create this data source". for postgresql. how to solve?

Hey Community,
I am trying to connect to Postgresql Server database from newly created Amazon Quicksight and I am getting below error:
“We weren’t able to create this data source.” Data source name postgres,
Connection type is only “Public network”,
DB Server, DB Name & port is 5433 inserted,
Username & password are correct for admin,
“enabled SSL” is not ticked as I do not enabled.
my other postgres data source is alsready connected and had no issue. why the new one is not being added?
Is there a specific words we should not use for our DB and passwords that may create issue while creating source?
How to solve it?

Hello @musama !

If you are sure that you have used the correct credentials, I would first make sure that you have created the correct permissions:

If those are correct, make sure that you have follow the correct configuration requirements:

Let me know if either of these help!

Hey @duncan Thanks for the reply.
I have both my postgres Databases on ec2 instance and both are accessable from outside.
The only difference is that 1st postgres DB is accessable on port 5432 and 2nd postgres DB is accessable on port 5433.
1st postgres DB with port 5432 gets connected on quicksight as datasource.
But the 2nd Postgres DB with port 5433 is not being connected on quicksight as datasource.

Both have same configurations.
Can you help me with this?


Hey @duncan
I am having this issue still. Is there something wrong with my docker postgres image I deployed on ec2 or is there something wrong with my quicksight settings?
Bcz I am not being able to connect to my postgres data source in quicksight.
i am stuck here.

Hello @musama !

If this is deployed on an EC2 instance, are you using a VPC? And if you are using a VPC have you made permissions for Quicksight to be able to access that database?

I would also just double check that the host name is correct.

Hello @musama !

Are you able to confirm my question above?

Hey @musama !

It’s been a while since we have heard from you, but would still like to help you find the solution. Are you still having trouble with this issue?

If we do not hear from you in 3 days this question will be archived.