Exclude column gives Modify dataset rules to exclude these columns. Error code: DatasetRulesUnknownColumns

Simple exclude of a column gives me this error.

I have a fact table in spice.
I have a a dim dataset that joins with the fact table, and applied row-level security.

Both the dim dataset and fact table have ‘tenant_id’, however beyond the scope for this question, I need to hide the fact attribute and let the dim dataset have a calculated field exposing ‘tenant_id’.

When I attempted to exclude form the fact - I get this error. I went to the dim table and removed row level security, and attempted to remove the column thinking QS is following its usage to the dim table with row security.

Nope - still doesn’t like it. What is this error and how do I clear it? I don’t create dataset rules.

Also have tired to ‘duplicate’ dataset but I get the error - not when row security is used. Turn that off - same error. Very flaky…

Based on your question it is my understanding that you need to have that column present in both of the tables.

A couple of things to try:

  1. Renaming the field you want excluded. This means you can then name the preferred field tenant_id.
  2. Excluding the field after you have joined at the joined dataset level. So you would join both of these datsets into one. Then go to that joined dataset and exclude that field.

Let me know if either of those work.

My issue is QS is throwing an error for no apparent reason. The data set had row-level security enabled and that used the column I want to remove. After turning row-level security off, there should be no reason why I can’t exclude that column. However it throws that error.

I also noticed you can’t ‘duplicate’ a dataset with row level security on. So I turned that off - still greys out that duplicate button. So row-level security appears to be sticky - QS isn’t clearing that status.

Did you try removing the RLS dataset by clicking Remove Dataset button the bottom of the page? Or you just turned off the RLS?

I’m not sure where that screenshot is from. I went back to where I setup row-level security. Hit that edit and turned off security, however (shown still on) the duplicate was still showing that message.

I basically had to start over to “duplicate” my dataset.

@sirwin007 after you click that ‘Edit’ button under the RLS section (like in your screenshot), you need to scroll down and actually remove the data set that was set for the RLS (dont worry, this is not removing this dataset from QS entirely, just removing its association with your other dataset). Using the ‘Disable’ button still doesnt allow you to Duplicate the data set. Then you should be able to duplicate it (just tried it and it worked).