Field based colors is not working

The field based colors are not getting applied despite assigning field based colors. The theme based colors are only showing. Is this feature turned on?

Hi Amita,
There could be a possibility that you have color applied on the visual level which have a higher precedence. Could you reset color on the visual level and check if the field colors show up. You can refer the blog - Reset color section - Introducing field-based coloring experience for Amazon QuickSight | AWS Business Intelligence Blog

1 Like

I have no custom colors defined.

Found the issue though.
If a theme is defined, the field based colors are not getting picked up.
If no theme is defined, the field based colors are getting picked up.

Hi @adevaraj,
Can you provide a video if possible and steps to reproduce this since we are unable to reproduce this issue internally.

There was something wrong with my account that was not allowing me to even edit the themes.

Now that that issue is fixed, the colors are also working correctly now.



Hi, I’m having issues with the field based colors as well. I read the blog post and reset at the visual level and it’s still not applying the colors specified, even tried changing the themes and color is not showing.