Filter shows no selection elements

I have tried to filter several times on the control which worked before, but after I filtered by selecting several selections and delete selected elements to filter with different way. After several times of filtering, my dashboard view’s filter started to show no options but only “All” for all filters so I cannot filter out any data, or even I choose “All” for all filter, dashboard view shows “No data”. I have tried to reset a filter, by clicking on the three dots on the right top of each filter and choose ‘Reset’, but it does not fix the issue. It looks like once filters are set, the filters will stay (even if you exit out) until you make a new selection. How can I refresh/reset the filter to see selections?

Quicksite dashboard:

Issue tab:Overall Trend tab.

Hi @Sunhee_Park

without access to your dashboard i would say you have to many regions to display.
If there are to many elements for a filter list, QS shows only the search bar.
Can you search for an element?


Hi @ErikG .
Thank you so much to check and answer!
No, I cannot search any element as well…

No elements in any of the filter?
Are the other tabs working?
The visuals saying “no data”, right?

@Sunhee_Park ,

Checking in. We have not heard back from you regarding your question. We’d still like to help. If we do not hear back in the next 3 days, we will archive the question.

@Koushik_Muthanna Sorry for my late reply. Thank you! Could you kindly help me fixing the problem?

Thank you for letting us know. I would recommend filing a case with AWS Support where we can dive into the details so that we can help you further. Here are the steps to open a support case. If your company has someone who manages your AWS account, you might not have direct access to AWS Support and will need to raise an internal ticket to your IT team or whomever manages your AWS account. They should be able to open an AWS Support case on your behalf. Hope this helps!