Heat Map labels are disappearing inconsistently

I have a heatmap whose title on X and Y axis is enabled. Sometimes the headers for the rows show and sometimes they don’t. I noticed that when there are too many columns (values on X axis) the row headers (Y axis) disappear. Is there something that is autohiding the headers because I have too many rows? Or is there something I’m missing? Is there a way to minimize the width of the individual cells within the heat map that might help resolve the disappearing headers?

image

1 Like

Hi Pyi,
Form what I can see from the image, there is hardly any space for the Y axis(Row) labels to render. Increasing the visual height should fix the issue Y axis label issue

Hi - if I want the labels to show I have to resize the visual to take up the entire screen which is not what I want. Is there a way to configure the size of the data points within the visualization instead?

Hello,
There is no option to resize the cells within the heatmap. They are automatically resize when you expand or shrink the visual.
A possible workaround is to use free-form layout writing manually the Y-Axis in a Narrative Visual and X-Axis in another Narrative Insight,after that you should have to play with the settings to overlap the 3 visuals and create the look&feel of a single one. In any case it will still be a static configuration.

@JoseB-aws can this be a feature request?

Hello,
Thank you @pyi, I will share it with product team and we will consider it.

1 Like