How to Avoid Misdirecting Email Link When Sharing Dashboards?

My use case is embedded dashboards. When I share with users they needed to go to the embedded link location to access the dashboard.

My problem is the autogenerated email directs them to AWS where the do not have a log-in, and that creates confusion.

From what I’ve pieced together, it sounds like there is no way to turn off the emails or replace the link with the embedded address. Is this true?

If so, the only solution I can think of is that if I add all new users w/in groups that would bypass all new ‘dashboard has been shared with you’ messages. Is this all correct?

If so, I would love to have a feature that leverages the embedded url settings or that would allow turning off the autonotification. I also would not want to be forced to send an email to a permissions group when new folks are added since that would create lots of confusion.

Thank you.

You can customize where the dashboard opens. Go to Manage QuickSight > Account customization > Email report template.

Thank you for the response, David. We do have the custom application set up, and it works well for emailed reports.

However the initial ‘A Dashboard has been shared with you’ email does not use the customized link. I’m hoping for clarification of how to avoid new report viewers receiving a link to AWS (where they don’t have an account).

Thank you.

We also embed dashboards in our SaaS application and when we share dashboards, our users don’t get any email but we never share with individual users. We create a group for all users who need access to the dashboard and we share with the entire group. Can you try that? I think that may make a difference.