How to fix 'Import failled' error?

Does anyone know how to overcome this?

I am trying to import to SPICE but, even when I try to use as Direct Query mode it throws the same error.
It only works importing to SPICE if I limit the query result to a very few records.

Thank you!

Hi @Goitom_Mehari

‘general SQL error’ usually happens when the SQL query run against the database has one or more issues.

Are you using custom SQL to create the data set? If so, can you try running the query using an IDE directly on the database and check if it works?

Also, clicking on ‘Show details’ in the error message would show additional details, including the exact SQL error returned by the database. Please provide a screenshot of those details as well if possible.


Hi @rajjaya!

Yes, I am using custom SQL and when I run the query directly on the database it works with out any error.
And also when I run the same query in Quicksight (Adding a limit to the query result to only 100 rows) it works with out any error and it imports to SPICE.

Hi @Goitom_Mehari -
Thank you for providing the screenshot. I would recommend filing a case with AWS Support where we can dive into the details so that we can help you further. Here are the steps to create a support ticket. If your company has someone who manages your AWS account, you might not have direct access to AWS Support and will need to raise an internal ticket to your IT team or whomever manages your AWS account. They should be able to open an AWS Support case on your behalf. Hope this helps!”