How to get text to wrap in table headers


I have a table with long column headers, but the text won’t wrap. It works with the pivot table but when I change it to a regular table it hides the text. I tried setting the row height to 500 and it still won’t wrap. How can I fix this?

Hi @Marie-LineF , Can you just go to the below solution I think it will help.

Currently QuickSight doesn’t provide any capabilities to adjust the header.

Thanks & Regards
Biswajit Dash

Hi @Biswajit_1993 , that’s what I looked at first, but it isn’t working for the regular tables, just the pivot table (see second image). When using the table with the same text, that isn’t too long to wrap it doesn’t work at all.
For exemple Video Interview Questions at text size Medium with the header row height set at 500 , it still won’t wrap the text.

1 Like

hi @Marie-LineF I understood your query can you please tell me which layout you are using is it Tiled or Floating. I think it is floating, if it is not please try with floating layout and increase the width of the header then it will works.

And also remove the Wrap Text from the formatting of the visual please find below the screenshots.

Thanks & Regards
Biswajit Dash


Hi @Biswajit_1993 Thanks for your help! You are correct I am currently in the floating layout. I tried what you just suggested just now by widening the headers and unchecking the wrap text, but it only shows the full text if I increase the width to be the same as the text but there is no wrapping happening at all.
I am trying to fit all the headers without having to scroll, which is possible with the pivot table but I don’t think I can wrap any header text with the table unfortunately.

1 Like

I’m also having an issue with table headers all of the sudden not wrapping. They were wrapping fine when this was created. I’ve even tried to increase the row height to 75 pixels (over the 50 pixel requirement) and it still is not working.

This is a table visualization with free form setting. This is just one example but we use two different accounts and are having the same issue in all of our dashboards/analysis.

1 Like

Hi, @Amanda_N_Avent thanks for sharing your issue and confirming that I am not the only one with this problem, seems to be a bug.

My table headers are wrapping now all of a sudden! Thanks for this input.
The moral of the story, if anyone is having an issue with this in the future, wait a day or 2 and try again, the bug may go away.

@Marie-LineF Glad to hear that this is working now. Please let us know if you see this again.