I got a INVALID_DATAPREP_SYNTAX error on my filter upon data refresh

Upon refreshing my data I got an error on one of filters saying INVALID_DATAPREP_SYNTAX – Your calculated field expression contains invalid syntax. Correct the syntax and try again.

I checked all the calculated fields they work well, I even tested on visuals just to be super sure there is no error and there was none. But now my dashboard has an error with no explanation on why and how it popped up…


How can I troubleshoot this issue? Am I missing a step?

Do you have any filters that are off?

Have you tried to replicate this visual from scratch?

Hi Max,

I checked my filters none of them are off. I have tried recreating the visual and I still get the same error. I have the same filter on another page with the same calculated fields where it works fine.

Hi @Shashwat

try to remove and then add the filter back in. Sometime refreshing the page does the trick.

if this does not work, then more details are needed to troubleshoot the issue: calculated field etc.


1 Like