Issues in connecting Aurora Postgres 14 in private subnet to quicksight

Hello All,
I am facing challenges in connecting Aurora postgres 14.5 in Private subnet to Quicksight.
Steps followed:-
a) Downgraded the password authentication of the DB from SCRAM to MD5
b) Created a new Security group with appropriate rules for Quicksight.
c) Modified the Private Security group of RDS to allow connection from Quicksight Security Group.
d) Created VPC on Quicksight
e) Tried creating dataset but getting error “We weren’t able to create this data source.”

Can someone please help as I am stuck on this from past 5 days. Tried everything I could but no success.


Hi @vkhilari ,

There’s an article on connecting quicksight to postgres14 here.

To verify these steps, I created an rds postgres 14.5 instance and duplicated your error, “…can’t create the datasource”.

Further, to verify that the issue was postgres 14 (and not the vpc connector or the security groups) I created an rds postgres 13.12 instance and re-used the exact same security groups. I was able to connect to the 13.12 instance using this VPC connection in quicksight.

With that, I was able to get past the error above and connect to 14.5 after I issued the following sql commands (per the article above):

set password_encryption = ‘md5’;
create user qs_user with password ‘xxxxxxxxxxx’;
grant connect on database dev to qs_user;

Note that I had to use this new qs_user in the dataset connection window.

Hope that helps. Let me know if that doesn’t work.


1 Like

Thanks @wstevens01 - It helped

Thank you @wstevens01 for sharing this solution. This is very useful.

Regards - Sanjeeb