Migrating asset from dev to prod and column not found issue

I am trying to utilize the import/export API to move assets around and was able to download the .zip file and uploaded onto s3. Before moving to the prod environment, I am testing to import back into the dev account with

'ResourceIdOverrideConfiguration': {
                'PrefixForAllResources': 'a'

However, I am encountering an error:
Error: [{Type: COLUMN_NOT_FOUND,Message: Column 9bdae4b8-7cc8-4972-8c40-0db599ba2f12, referred in the Definition object 1 time, is missing in the DataSet axxxxxxxxxxxxxxxxxxx.,ViolatedEntities: [{Path: data-set/tablename/column/9bdae4b8-7cc8-4972-8c40-0db599ba2f12}]}.
Since I am importing into the same account, why would I get this error? and what exactly is this column with this column name?
Tried to use describe_data_set but there is no such column in the table.
Thank you!

Hello @zoomjin, welcome to the QuickSight Community! In this specific example, what resource are you trying to import back into the dev account? Is it dataset, analysis, or dashboard? That might help me find a solution to the issue you are facing.

its a analysis that I am trying to import back

Hello @zoomjin, check the definition of the analysis to see where that Dataset column is referenced, this would show up in a visual or dropdown for example. If the “ColumnName” attribute is a uuid, I would assume the definition wasn’t generated correctly, unfortunately these APIs aren’t perfect yet. What you’ll have to do with these import/export jobs when using the raw definitions pulled using the APIs is to go through the errors, fix them in the definition, then try to deploy again. So for this case, what you can do is trace where the failing column name is used back to the existing visual/etc. and fix the column name in the definition to the one that should be there.

Thank you! I will test is out, qq, would the porting content method work better in this case? or it would be the same?

Hi @DylanM - Is it possible to raise this as a bug internally as if the API are not stable, it should be in preview stage not for use enterprise way.

Regards - Sanjeeb

1 Like

Hello @zoomjin, do you mind explaining a bit more what you mean about “porting content method”? I am not sure I understand. As for this method, my team has used it a few times and while it can be a bit tedious, especially while learning it, I believe it is the best solution for the time being.

@Sanjeeb2022 one of our clients have raised a bug to the support team for this exact issue already!

1 Like

Not sure if you team have tried this and if this is of any difference compared to API.

Hello @zoomjin, I will definitely dive into that information and appreciate you sharing. If you need anymore assistance on this issue or do not have any luck with the solution I suggested above, let me know!

Thanks @DylanM for provide the details. Hope internal QS team is looking these bugs. We will wait for the outcome down the line.

Regards - Sanjeeb