Number formating in Filter

I have set number format for numeric fields in visual, but when i set this field as filter, then i have no option to set number format to be used for displaying.
e.g. I have number values in dataset as 100.1, 100.5.
I want to display it in different region where decimal separator is COMMA. So I set number format on field and it displayed like

But when i set field on this field and if i choose list control option it still shows values like
Even with text control option, i am unable to use , as separator during filtering.
I tried setting language properly where Comma is used as decimal separator

Any solution for this?

@Saurabh ,

The number formatting works for the visuals. For filtering the format still uses “dot” for decimals.

I will mark this as a feature request for being able to use the formatting in filters/controls.

Kind regards,

Thanks @Koushik_Muthanna for considering this as feature request. If defining format is not feasible then it should at-least by default work on field formatting.