parseJSON works during dataprep, but produces error during analysis and refresh

Hi, I have a similar issue with MaheshJ, as stated here: MaheshJ’s question

During dataprep, I did not encounter any error and the data preview below shows exactly what I needed.

Im using the following calculated field: parseJson({column1},"$.myId")
The data preview looks good, and it skipped null values, as expected.

However, it cannot be saved & refreshed with the error:

A calculated field contains invalid syntax. Correct the syntax and try again.
ParseJson can be applied to a Json Field

The dataset is from postgresql. The columns are normal, but one of the columns has a text data type that looks like JSON. There is also a NULL value, the column data looks like this:

row 1: {"myId":"abc123-def", "anotherId":"hijklm"}
row 2: {"myId":"opqer123"}
row 3: <null>
row 4: {"myId":"vwx123"}

I tried selecting query mode from SPICE to direct query, getting the id during analysis, but the same error pops up.

Anybody else with the same issue? I would like to know how you would resolve this.


Thank you for sharing this question.

Please review this previous thread, it appears to be similar in nature to the issue described in your post.

1 Like