Problem with rules on a filter


I created a filter with a rules that if the groupName (soterd as parameter) of the RSL “is equal” to Admin, the filter is showed. And it works fine.

However, now I created some other groups as XXXX_Admin, YYYY_Admin and I changed the rules to “contain” Admin butI do not see the filter…

any suggestion?

thank you

Hi @remba87,
I tried this and contains worked for me. I believe the text entered in the rule is case sensitive, can you check if your group name and the contains text use the same case?
Admin vs admin.

thank you.

Hi @Asem,

I think I understood the problem…
I created two groups: one able to see XXX data and another to see YYY. Then I put the same email in both groups.

Maybe when logging in, the parameter connected to the RSL is not correct since probably it does not know how to choose between the XXX and YYY? Am I thinking correctly?

I then created 1 group XXX_YYY_Admin and it worked…

I see there are a few moving parts here, with RLS rules and parameters alongwith users belonging to multiple groups. Are you using dynamic default parameters? How did you tie a parameter to RLS?

I’m glad its working for you now though.
Feel free to share screenshots so we can also visualize the issue if you have further questions on this.
I’ll mark this resolved for now.