Hi team,

We have an enterprise QS account that has occupied ~13TB SPICE capacity. We found 500+ datasets on SPICE that are not updated in last 180 days. To make best use of SPICE, we decided to update the inactive datasets from SPICE to DIRECT_QUERY.

When we tried to programmatically update the datasets ImportMode from SPICE to DIRECT_QUERY. We are getting below error and are unable to proceed further. Can you please help us in getting unblocked.

botocore.errorfactory.InvalidParameterValueException: An error occurred (InvalidParameterValueException) when calling the UpdateDataSet operation: Only SPICE dataset can have sub-type.

Hi @PraveenKumar
Does this happen with all the datasets or only specific ones. Can you please check if the dataset pulls data from multiple data sources?

We have there AWS account (beta, gamma, prod) and this is happening in all QS accounts and for all datasets

Hello @PraveenKumar !

Are all of the datasets coming from the same datasource (for example: Athena) or are you using multiple for your different datasets? CC: @n_vetri

This was a bug and QS team has fixed it.

1 Like