Quicksight embed in Sharepoint

Hello Community,

I want to embed Quicksight on a Sharepoint side.


  • Settings in ‘HTML field security’ , the Quicksight Server was added
  • I created sharepoint webpart and embedded the code from Quicksight

Unfortunately ist is shwon that Quicksight is “rejecting” the access, please see picture.

Could someone help me ?
What I didn’t have is the modification in Quicksight to publish in internet, this Option I didn’t have in Qusicksight.

Thanks in advance


1 Like

Hello @Turbat1, 2 important things to consider when whitelisting domains in QuickSight. First off, it is fine to use http when you are whitelisting localhost, but any other url will require https. Also, you can utilize a format like this https://*.sapp.amazon.com for a url to manage subdomains for a certain website. I am wondering if the issue you are facing is related to one of those 2 issues. Let me know if this helps!

Hello Dylan,

thanks for your support, I also turned the “public” on, and embedd the Code into sharepoint.
Unfortunately still not working…?

I think this is an issue at AWS side, did you have any Idea ? Regarding Access and settings.



Hello Turhan,

Do you have standard or enterprise subscription ? i assume you are doing one click embedding and enabled public access. if so please make sure it uses session based pricing.

Hope this gives some idea.

Hello Deep,

yes , we choosed “session based pricing”, still the same…

Our Quicksight Dashboard is marked as “public”

Thanks in advance.



1 Like

Hello @Turbat1,Thank you for letting us know. At this point, I would recommend filing a case with AWS Support where we can dive into the details so that we can help you further. Here are the steps to open a support case.

If your company has someone who manages your AWS account, you might not have direct access to AWS Support and will need to raise an internal ticket to your IT team or whomever manages your AWS account. They should be able to open an AWS Support case on your behalf. Hope this helps!

Hello Dylon,
thanks for sharing, I contacted the AWS support and we checked everything via screen sharing.
It was your solution that you mentioned here:

  • I referenced the full link to the sharepoint website → This caused this issue and it is not possible to publish

  • When I refence only to the server, like you described in this post → The access is possible.

Thanks for your support.



1 Like