Quicksight support for Amazon postgres RDS 15.3

QuickSight cannot connect to AWS postgres 15.3 RDS and complains about the authentication type 10 is not supported.
I created a new logon rule with password_encryption set to md5 but still cant get the connection to work.

Hello @alsagheer , welcome to the Quicksight Community!

Can you try the solution posted here for a similar issue?

Let me know if this helps!

Hello @alsagheer !

Did the link I posted above help you with your question, and if so can you mark it as a solution to help the community?

If you are still having trouble with this problem we would like to help, but we haven’t heard from you in a few days. If we do not hear from you in 3 days this post will be archived.

@duncan thank you for the link, in fact I already created a separate user with md5 enabled but got the same error as I mentioned.

Hey @alsagheer !

I’m curious if it’s something else then. Are using this in a VPC? If so I would start with the security group set up and make sure that it is correct to rule that out.

When I misconfigure connectivity aspects e.g port or access group rules I get a different error which confirms the “GENERIC_SQL_EXCEPTION The authentication type 10 is not supported” comes out from the destination database which is reachable.

Hey, did you get this to work? I’m facing the same issue and have no clue other than switching to md5.

I created a user with md5 support but still not working.

Well, I figured out my case, turns out that if you change the password_encryption parameter of a rds replica it keeps the password_encryption parameter of the main instance. After changing the password_encryption to md5 of the main instance, rebooting, and changing the password of the user I wanted, it worked. Hope this helps.

Hey @alsagheer have you tried @llanza’s solution?

Hello @alsagheer! It’s been a few days since we’ve heard from you and would still like to help solve your problem. If we do not hear from you in 3 days this question will be archived.