Really big default column width in tables

When I make a table I frequently have an issue where the columns are really wide. It’s always the columns that contain a lot of text, but the width is much greater than the largest text value in the table. The thing is I don’t see a way to manually set the column width or a limit to the column width. To resize them, I have to scroll to the edge of the column and repeatedly click and drag it over to the left. It’s really annoying.

Is there really no way to just manually set column width? If no, why not?

Hello, there is currently no option to manually set the table column width, however we will take this under consideration for future enhancements to the table visual.