ResourcePermission list contains unsupported permission sets

Hi! I am trying to create an analysis with the rights:

 private readonly List<string> _defaultAdminPermittedActions = new()

        private List<string> _defaultUserPermittedActions = new()

        public List<ResourcePermission> GetAnalysisPermissions(string userId)
            return new List<ResourcePermission>(2)
                    Principal = _awsConfig.AdminAccountPrincipal,
                    Actions = _defaultAdminPermittedActions,
                    Principal = userId,
                    Actions = _defaultUserPermittedActions,

The created analyses has status “creation fails” :

        "Status": "CREATION_FAILED",
        "Errors": [
                "Type": "VALIDATION_ERROR",
                "Message": "ResourcePermission list contains unsupported permission sets [quicksight:RestoreAnalysis, quicksight:UpdateAnalysisPermissions, quicksight:DeleteAnalysis, quicksight:DescribeAnalysisPermissions, quicksight:UpdateAnalysis] for this resource. Valid sets : [quicksight:RestoreAnalysis, quicksight:UpdateAnalysisPermissions, quicksight:DeleteAnalysis, quicksight:QueryAnalysis, quicksight:DescribeAnalysisPermissions, quicksight:DescribeAnalysis, quicksight:UpdateAnalysis]"

It doesnt matter, which set of permissions I try to grant, it fails anyway. It seems especially strange because valid set of rights contains all these rights that are listed as not supported.
Any ideas how to fix it?

Hi @NataliaZ

The API expects all 7 permissions below:


Please try updating the permission set and let us know if the issue persists.

Hi rajjjaya and thank you for your answer!
I have already tried any combination of rights from one “quicksight:DescribeAnalysis” to them all. The error still existing.
I suppose smth is wrong in the config or in the rights of the user creating the analysis.

The issue solved:

  1. first create an analysis without specifying permissions
  2. grant permissions