Security lake Athena db not visible for dataset selection

recently i tried security lake service which is just launched by AWS, I did followed all the required steps to run security lake, I was able to get my security lake created in s3 and able to see my data in ATHENA DB, but I am wondering can I visualize this data in Quicksight?
Because when I am trying to add this security lake database as a dataset in Quicksight I am not able to see the database name in list when I select athena as a source.
though I was able to see my other database in that list.

if anyone does has any solution on this please do let me know…

Hmmm, I haven’t worked the the security lake service yet.

Are there IAM policies that are attached to it? If so, you might need to attach a policy that allows the quicksight user role to access it.

umm, i am not sure but i guess yes as I was able to see my default athena DB and its tables. its like, security lake’s DB is not even in list of Databases.

Just an update, i am able to fetch the database and Tables of Security lake in Quicksight.
It was an Lakeformation permission issue we need to give permission to quicksight ARN of those Database and tables

1 Like

Hi, I am encountering the same issue. Hope you could help me with the solution.

In my Account A, I have a security lake with data like Security Hub findings, VPC flow logs, and CloudTrail logs stored in S3 buckets. I have enabled Lake Formation and it detected the S3 buckets datas and automatically created corresponding databases and tables in the Glue Data Catalog.

In Account B, I am querying this data from Account A using Athena. I created a database resource link in Lake Formation which configured the databases, tables, and partitions in Athena (which i guess is metadata). I am seeing the database and tables in Athena and also can run queries. However, i am not able to fetch the database and tables in QuickSight.

In Account A, I have granted lake formation permission to Account B. However if i tried to grant a permission to QuickSight ARN (Account B) , it fails. :smiling_face_with_tear:

Hope you could help me here! If you need more details then i can provide you! I apologize for the long message!

Hi @SaulGoodman - You may need to created a trusted policy so that Account B QuickSight should have access to Athena table in Account A. The best way to fix this issue to raise a ticket to AWS Customer support team so that they can guide you. To raise the ticket, please follow the link - Creating support cases and case management - AWS Support

Regards - Sanjeeb

1 Like

Hi, thank you for responding. :slightly_smiling_face:
QuickSight and Athena are in the same account, which is Account B. In Account A, I have enabled security lake and lake formation, and data is stored in S3. I have given cross-account access to the S3 bucket to Account B and have also granted data lake permissions (for databases and tables) to Account B, which allows me to see the databases and tables of Account A in my Account B.

1 Like