Spice full refresh still referring to old column - fails refresh

I’ve updated my dataset, and removed a column that was once used to drive incremental refresh. I’ve replaced this column with a different column.

The dataset updates, saves and publishes fine - no errors.

I issue a FULL refresh and I get an error about the old column not found.

  • deleted the incremental refresh schedule - still fails
  • tried to change spice to direct, then back to spice (that part worked) - but when switched back it still fails and all old history is there (not expected)

How do I get spice to forget about this old column?

I think this is related to the incremental refresh history - a full refresh works in dev where incremental was never setup. In Staging env I had incremental setup, and here it fails.

I don’t want to have to create a new dataset - ci/cd process uses existing guid - when this should be easy.

Can you go in an publish the new dataset without the column?

1 Like

Hi @sirwin007

We have not heard back from you regarding your question. We would still like to help. If we do not hear back in the next 7 days, we will archive the question.