The created dashboard with AWS CLI does not appear

Hello everyone, I have been following this guide to migrate a dashboard from one AWS account to another. I was able to create the new dashboard, but it does not appear in the QuickSight UI. When I run the ‘list-dashboards’ command, I see the dashboard created through the template from the other AWS account. However, upon accessing the QuickSight UI, it does not appear. If I input the dashboard’s ID in the URL, it informs me that I do not have permissions or that it does not exist.

Hi @diego.agrology - You need to give the permission to the user so that the dashboard can be visible to the user. Please use update permission api for the same. See the documentation for the same.

Regards - Sanjeeb

Thank you for the response. When creating the dashboard, I gave it the permissions specified below, yet I still can’t see them. Is there any permission I might have forgotten?

    Permissions = [
            "Principal": "arn:aws:quicksight:us-east-1:9********9:user/default/diego",
            "Actions": [
1 Like

The issue was that there were errors while creating the dashboard, but they were not displayed in the console. I corrected the dataset fields, and it worked. Regards

1 Like

Thank you @diego.agrology for sharing the details.

Regards - Sanjeeb

Hey @diego.agrology,
I’m facing similar issue, can you elaborate more on how you corrected the dataset file.