Unable to load file from S3 to QuickSight! Parse Erorr

Hi Team,

I tried connecting to S3 from Quicksight, I uploaded the Manifest.json file, It got connected but when I click on Visualize it says an error!

“This file format isn’t supported. Amazon QuickSight can’t parse the file.”

I have only .csv file uploaded in S3, file name is simple without any spaces on the name. Not sure whatelse is going wrong!

Hi @kodimalar.sakthivel - Can you please give a screenshot of the error, it will help us to understand the issue in details. Also please check if you have followed the steps mentioned in the link - Creating a dataset using Amazon S3 files - Amazon QuickSight

Regards - Sanjeeb

1 Like

Hi Sanjeeb,

I resolved the issue, Actually when I loaded the CSV file in S3, I have the manifest.json file which is having my CSV file name, I uploaded the manifest.json file, It said couldnt parse the data on a pop-up, pop-up also had a Edit Dataset option.

On Edit dataset screen I right clicked on the connection name and saw “Configure upload settings”!
There I saw the file-format was default to CUSTOM, that I changed to CSV then it worked and loaded the data and showed the preview columns.

May be by default QuickSight is taking CUSTOM as file-format. Not sure how to change it while connecting. I had the manifest.json file like this.
“fileLocations”: [
“URIs”: [
“globalUploadSettings”: {
“format”: “JSON”,
“delimiter”: “,”,
“textqualifier”: “'”,
“containsHeader”: “true”

1 Like

Thanks @kodimalar.sakthivel . Glad to hear the issue is resolved now.

Regards - Sanjeeb