Updated excel file with new rows of data and analysis won't read the new rows

Hi I have used an excel file in my analysis with 4 months of data. I have just uploaded a new data set with 5 months of data. Same columns, more rows. The Analysis will not read the new rows with the new month data.

I’ve used the same analysis and replaced the data set. I’ve refreshed the data. Nothing seems to make a difference. To recreate the 3 sheets of analysis will take a long time and I was hoping to use that as a template but if I can’t replace the data files that won’t work.

Hi @kjaques

what is the error your’re getting?

Usually this happens when the new file “looks identical” but there are different data types for some fields? Can you check?

How do you upload the new excel file? Are you replacing the current file? Removing the current file and then uploading the new file?

More info will help us troubleshoot the problem.


The data types should be identical on the excel as I added them to the original excel and renamed it, but I will check them now.

I am replacing the file, but nothing happens. I have tried removing the file, deleting the file and reloading the file. Nothing changes.

Dates seem to be an issue but not sure if this is related to this problem. The date format is defaulted to m/d/y. Outside of the US the dates are usually d/m/y and this is causing me some issues, but I don’t know if this is part of the problem here. I know it’s not reading the file rows, because my visual totals are not changing if it was a date formatting issue.

oh and there are no errors.

Hi @kjaques

There are two ways to replace a file. In the data prep or the analysis layer. Have you tried to do it in both?


Yes I have tried it both ways.

When I open the analysis it shows the 23,000+ rows loaded, but only 17,000+ are being used, which means that the month I added ( those extra 6,000+ rows) are not showing. The entire month of January is not being added. Before it was FEB to MAY. I received January and added into the excel and loaded in the file under a different name. Saved that file and published it. Then replaced it the analysis layer. When that did not work. I tried in the data prep. There are no errors.

What I have noticed is if I use that file in a new analysis all the data is there. It just doesn’t seem to be loaded into the analysis I originally built.

There seems to be a problem with the date field for January.

Hi @kjaques

so the data is loaded but it is not showing up in the visual? There is no issue with uploading the data, the newly added month JAN is showing up but not in the way you expect. :slight_smile:

The new month has the date in a different format than the rest of the rows. Why? Not sure unless I see the data. One thing you can try: In excel create another DATE column and populate it with the dates from the date column but make sure the column uses a consistent date format down all rows. Or try anything that ensures you have the same date format in the original date column.

Hope it helps,

Yes, this is what I’m looking at now the data prior to entry in QS. Thanks for the advice. I will post if anything new occurs. :slight_smile: