Urgent: No data in analyses/dashboard, but dataset has 'Data'

Hello, I am now building an analyses, and for one of the metrics, the data shows up perfectly on the dataset page. However, when I was building the analyses, there was no data for that metric!!! Does anyone know what is going on here?? Why is this happening?

For additional procedures, I’ve tried:

  • I published the analyses to the dashboard, and still no data for that specific metric.
  • I refreshed the dataset multiple times, and still no data for that specific metric.
  • I’ve created a blank new sheet and visual and added only that metric, and still no data.

Everything else works perfectly!! Please assist. Very urgent. Thank you.

Hello, if you’re not using any filter but the data still can’t see, I would recommend filing a case with AWS Support towards Quicksight team. Please use “Chat” method and give support engineer a link to join your screen sharing session. That’s the fastest way to resolve it. Hope it helps.

Hi @irinaaaaa
any RLS implemented, is the metric a calculated one, did you republished the dataset?
BR

Hello @ErikG,

  • What is RLS?
  • the metric is not a calculated field, it is a metric that directly comes from the database.
  • The dataset was refreshed multiple times, if that is what you meant by re-publish

Hello @Sophia,

Any recommendations regarding what I should do? What might be the cause it? Anything I can try to solve this on my own?

In general, is it possible to do a direct query refresh to a dataset with only SPICE refresh available now? I suspect a direct query refresh might solve this problem.

Overview of my dataset:

  • Two big datasets left joined together from different databases.
  • The Direct Query button (aka. little box) is not showing up for this dataset.

Hi @irinaaaaa

  • Row Level Security
  • no I meant edit → save & publish
  • in general you can switch from SPICE to direct query. If both datasets are using the same datasource.
    BR

Hello, usually data shown in dataset but not in analysis due to the following reasons:

  1. Joint dataset never republished to be used by analysis
  2. Row level security (RLS) or Column Level Security (CLS) policy restrict it from viewing by the user
  3. Joint result not happened properly in SPICE

Accordingly, you can check:

  1. If you’ve republished the joint dataset
  2. If you have any RLS or CLS restrict the metric from viewing for this author or user
  3. Use direct query. I suggest you check if this metric will show up without JOIN operation (load that dataset individually and plot a chart in analysis). If that’s okay, then it’s the JOIN issue.

Hope it helps.

Thanks @Sophia and @ErikG,

  1. The joint dataset was edited, saved, and published for multiple attempts on multiple days. And it doesn’t help.

  2. No RLS and CLS is applied to the dataset

  3. I’ll check if the metric will appear from the individual dataset.

    • For a comprehensive context, the dataset I’m using is created by joining two datasets from different databases. Any chance I can do the direct query for both datasets individually from the datasets page, given that direct query is not available for both datasets that are not from the same database? OR whenever two datasets from different databases are joined together, I’m unable to do a direct query?

Hello @irinaaaaa , @Sophia , and @ErikG !

@irinaaaaa were you able to try @Sophia 's last suggestion of importing both datasets individually without the join in direct query to see if you can load the metric or were you able to find another solution? if you were able to find a solution could you share it with the community?

Hello @irinaaaaa , @Sophia , and @ErikG !

@irinaaaaa were you able to attempt @Sophia’s last suggestion and try importing the datasets individually or were you able to resolve this problem on your own?

It has been some time since we have heard from but would still like to help you find a solution. If we do not hear from you in the next 3 business days this topic will be archived.