We can't open that dashboard

Hi There,

Our QuickSight users have been getting a We can’t open that dashboard error once a while.

They are typically setup using their email ID and IAM User as No:

When they report the issue I can see that they got into QuickSight (based on time stamp) and the error is related to access to the dashboard.

The users have been in there for a while, there is no change to access and hence I don’t really understand what is going wrong.

My current workaround given the urgency of the issue to the users is to remove them and send them a new invite and add them back to the Shared folders through which their access to dashboards is controlled.

They are then able to access the dashboards without issues. Is there any admin option to emulate as the user to test what could be the issue or any other way for me to find root cause for this issue?

Regards,
Giri

Hello @Giridhar.Prabhu !

Has anything changed to the underlying analyses or datasets that feed the dashboard? For example, did you add new datasets or replace any datasets?

To recreate the issue my suggestion would be to create a new user email with and provide that email QuickSight access.

1 Like

do you have multiple QuickSight or only one QuickSight account? this can happen when user already login to one QuickSight account and trying to access dashboard in another QuickSight account

2 Likes

@royyung We have only one QuickSight account

I can certainly try and create a new user email and give access and test when this issue occurs. Thanks for the suggestion.

2 Likes

Hello @Giridhar.Prabhu !

No problem!

Again, my best guess is that some QuickSight resource might be added when you push the updated dashboard to production and your users do not have read access to the underlying resource.

Hello @Giridhar.Prabhu !

Were you able to run those tests?

I have created the account. But I haven’t been able to re-produce this case. Will use this if the issue occurs again and provide an update

@Giridhar.Prabhu - This may also occur if the user has been given access via one IAM Role (federated access) and they are trying to access the dashboard while they are logged into another role which doesn’t have access to QuickSight Service. Please keep this group posted on your updates so that others can benefit from it who are potentially facing similar scenario. Cheers!

1 Like

Hello @Giridhar.Prabhu !

Were you able to troubleshoot based on @sagmukhe’s suggestion?