Alert has been turned off. why?


I tried creating an alert using the new alert feature for pivot tables and got the notification described in the snapshot:

What is the reason for that?
I tried changing the threshold, disabling and reenabling the alert but it didn’t help.

Thank you

HI @amico ,

Can you go to the below articles where the AWS team described the Alerts related topics in more details.

Thanx & Regards
Biswajit Dash


There is no reference to this kind of bug within the article. I also didn’t find something across the web.
Do you have any idea why this might happen?


Hi @amico can you recheck with your Threshold value I think there is some gap in the alert setup so that it is not giving you the exact alert.

Thanks & Regards
Biswajit Dash


It is actually very simple alert that is based on calculated field, which is in absolute number format.
It’s diff between current and previous month amount metric.


Hello @amico can you please share with us a screenshot of the alert configuration in the dashboard? This would allow us to see why it may be failing.

A screenshot like the following (at dashboard level) will be very useful (make sure you have clicked on the :bell: icon so the alert config is shown in the right pane):

Also you can click on the history tab to see the history of alerts and share with us if there was any error reported there.

My understanding is that either the alert configuration or the visual definition (filters and or fields) is no longer valid and it is causing this issue.

We will wait for your reply.

Thank you, regards.

1 Like


I hit a cell with value 1.05M in a table and then clicked Create Alert

Afterwards I just defined the condition and threshold.

Clicked SAVE and that’s it.


Hello @amico thanks for the info, cab you also show the history tab (in the reader experience -dashboard-) for the alert to see why it might be failing please?

I am particularly interested on the highlighted section:

This should allow you to diagnose what is going on.

Thank you, regards.

1 Like

@EnriqueS No history records.

Hello again. I was able to reproduce the issue and in my case this was the way I was able to get to the same situation as you and then enable back the alert:

  1. Create a table alert

  2. “Break the alert”, in my case I added a very restrictive Row Level Security set

  3. I got the same message as you, I clicked on the image button on the email to go to the affected dashboard (see image 1 below)

  4. Then I clicked on the enable button again and I was able to receive the alerts again (see Image 2 below)

Image 2

In this the alert was switched off due to having missing data on the visual (due to RLS, filters or actual missing data in the dataset). When this happens the alert needs to be manually set on again.

For more info about how to troubleshoot alert failures please refer to this documentation link.

Hope it helps, please mark this solution as solved if that’s the case also to help other members of the community., otherwise let us know.

Happy dashboarding!


I will try it and update.

1 Like


I tested what you offered and the alert still being disabled.
There is data on the visual.
Yet there are other visuals in the dashboard with No Data notification.
Can this impact the visual with the alert?



Hello @amico , sad to hear that.

No, according to the doc the alert should be only disabled if any of these conditions are met at any point in time (would be worth checking the state of dataset associated to the visual at the specific time you get the email saying that the alert was disabled):

To investigate why an alert failed, check that you still have access to the dashboard. Also check that you have permissions to the correct dataset and to the correct rows and columns in the dataset. If you have lost access or permissions, contact the dashboard owner. If you have the necessary access and permissions, you might need to edit your alert to avoid future alert failures.

Is this visual associated with a SPICE dataset configured for auto-refresh? If so, can you check on the dataset refresh history if the refresh time matches the time you received the email for the disabled alert notification?


1 Like


Yes it was in the same time.
The spice dataset finished its auto-refresh and than an email of notification turned-off sent.
I have full permissions for the dataset, analysis and dashboard where the alert was set.
What can be the reason for the disablement?


Hi amico, I was able to regenerate the scenario and alerts are enabled for the dashboard. Are you facing this issue for all dashboards that uses this dataset or just this dashboard alone?

1 Like

Ok, thanks for the confirmation. Will send you now a DM with the next steps and will archive this topic as this could be caused by a particular bug we need to investigate.