Cannot see map visualizations for geospatial data

I have a dataset with latitude and longitude - I have set them up in a coordinates hierarchy per the documentation. However, in the “Visual Types” panel, there are no map visual types at all. When I drag the coordinates hierarchy into the auto-visual, it says “This type of chart is unavailable in your region.”

Our home region for Quicksight is Ireland: eu-west-1. I’ve tried buying some SPICE capacity in N. Virginia (us-east-1), and uploading the dataset - same issue. I believe both of these regions are supposed to support map visualizations. (At least, according to a page I’ve now lost).

We have had an Enterprise version of Quicksight from before Geospatial data was available. Perhaps an upgrade is required. Or, what am I missing?

How can I get map visualizations enabled?

Many thanks.

does the dataset recognize your lat/long fields as being latitude or longitude. In other words, as shown in this screenshot, does your field named latitude have the word latitude as second time, indicating that QS recognizes the field as containing latitude data? It will also have the balloon like icon indicating that the type of the field can be used as a position.
image

Hi cgreenacre, thanks for the response.

Yes, the dataset is recognizing the fields as lat/long:
image

Well, well, after a few days, the capability has appeared in our Quicksight account. I haven’t had any feedback about why this has been resolved… I suspect that following up with AWS through the partner of theirs we work with did the trick. But I’m not sure yet. If I find out more, I’ll post here with exactly what needed to happen…

Finally found out the cause: using a VPN will sometimes cause the functionality to disappear.