Date Filter Does Not Allow Empty/Blank/Null Values as Default

I have an older version of a quicksight dashboard that uses multiple date filters (and corresponding controls for each of them) for many different date data fields. The underlying data has a lot of nulls for the dates.

On this older version of the dashboard, the dates in the control selection range by default are blank. This results in all of my rows in the dataset pulling through to the results.

However, if I copy the dashboard to a new analysis and attempt to edit the date filter (even as little as opening the filter and hitting apply, without changing anything), I cannot, as I receive a red error stating “Select a date.” for the start and end dates in the filter.

The issue is that if I choose a wide range of dates, dates with nulls are excluded. I can set it to “include nulls”, but this does not replicate the behavior of the older dashboard because the old one was essentially functioning as “include nulls UNTIL a date is entered into the filter controls by the user, at which point exclude the nulls.”

My only options for the new filter are to “exclude nulls”, “include nulls” or “nulls only.” None of these options work because it does not replicate the behavior of the old dashboard. Exclude nulls is closest, but because I am now forced to enter a start and end date (rather than leave them blank like the old dashboard allowed), rows that have nulls for any of the date filters are completely excluded.

I think you can infer how this becomes a problem as the number of date fields increases; this essentially results in either no results being included if I use “exclude nulls,” and virtually all rows being included if I use “include nulls.”

How can I get the behavior of the old dashboard?

Any ideas on how I should approach this?

Hi @auaaau0 ,

Checking in. Are you still facing this issue ? . Could you provide a few screenshots regarding this behavior ? . If we do not hear back in the next 7 days, we will archive the question.

Kind Regards,