Error when connecting to Athena Data Source

Hi,
I get the below error when trying to connect Athena datasource in QuickSight.

sourceErrorCode: 100071
[Simba]AthenaJDBC An error has been thrown from the AWS Athena client. Permission denied on S3 path: s3://xxxxxxxx

sourceErrorState: HY000
sourceException: java.sql.SQLException
sourceType: ATHENA

The data is json. file residing on S3 bucket - connected to Athena via glue crawler.

Troubleshooting:

  1. I’m able to successfully run queries in Athena directly.
  2. Verified the Manage quicksight permissions - all recommended permissions are assigned to buckets & Athena.

Please help!

Quicksight need access to both, the Athena query results bucket and the S3 bucket which actually stores your data files that you are trying to visualize in Quicksight. Please make sure you give access to both in Manage QuickSight > Security & Permissions > QuickSight access to AWS services > Manage > Pick all S3 buckets

Neeraj, as mentioned in the original post the access to all s3 buckets are granted and cross checked all the IAM permissions recommended as well. Still no luck.

Can you uncheck on check the Athena permissions in the settings and make sure it has access to that bucket?

Hi, @arunvg Did this get resolved for you? Let us know if Max’s recommendation helped. Thanks!

Kristin, No it did not. What max suggested is repetition of what I already described in the original post. I even deleted my quicksight account and recreated & followed all the permission guidance along with check , uncheck procedures.

Hi @arunvg ,

I would recommend filing a case with AWS Support where we can dive into the details so that we can help you further. Here are the steps to open a support case. If your company has someone who manages your AWS account, you might not have direct access to AWS Support and will need to raise an internal ticket to your IT team or whomever manages your AWS account. They should be able to open an AWS Support case on your behalf. Hope this helps!

Regards,
Koushik