The newly added Text Visual can't display formatDate(${parameterDate}, 'yyyy-mm-dd'), it always defaulted to bigint timestamp

I want this:

but got this instead:

Tried to format the parameter using formatDate(${parameterYesterday}, 'yyyy-mm-dd'), but it keeps jumping back to ${parameterYesterday} once the visual is deselected.

Anyone has any luck displaying dates in desired format on the text visual?

It might be throwing an error because of the format you are putting in.

Months need to be capitalized.

Try formatDate(${parameterYesterday},‘yyyy-MM-dd’)

Thanks Max, but it doesn’t work. I’ve also tried using double quotes instead of single quotes, doesn’t work as well

Hmm it might be a bug with the new text editor.

I would suggest opening up a case.

Here are the steps to open a support case. If your company has someone who manages your AWS account, you might not have direct access to AWS Support and will need to raise an internal ticket to your IT team or whomever manages your AWS account. They should be able to open an AWS Support case on your behalf. Hope this helps!