Calculated field unknown error

I have this already existing calculated field in my analysis, and it works exactly as I need it to, but I would like to change the title from {running_average_quantity} to {running average quantity}. When I change the title (nothing in the actual code) I get the error “we encountered an error trying to save your calculated field. please try creating it again”. I also get the same error when I try recreating the field, with any name. Since there are no details in the error, and the calculated field currently works fine, I am unsure of where the error is coming from. The purpose of the field is to take an average from the previous three years. The {running actual quantity} is a running sum of quantity by either calendar year, fiscal year, month (not actual running), or quarter, which is set by a parameter control. And the data is viewed by date truncated to month. So for example if it’s Feb of 2022, and I have my parameter set to calendar year, then my {running actual quantity} for this month would equal a sum of quantity from 1/1/2022-2/1/2022. My {running average quantity} would equal a sum of quantity from (1/1/2021-2/1/2021 + 1/1/2020-2/1/2020 + 1/1/2019-2/1/2019) / 3. Has anybody encountered a similar error and found a solution, or figured out what causes this this type of error message? Let me know if I can provide further clarification, thanks.

I was able to make a field and rename without issue using the same formula with different fields. It seems like a bug if it’s causing trouble for you. Do you run into the same thing if you copy/paste this into a new calculated field?

Something to try:
-Copy paste the formula into a barebones text editor (something without rich text formatting) and then copy it back into the editor or just re-type it manually. It’s possible a special character could be getting set during the editing display that’s different from what you’ve previously saved.

1 Like

Hi,

I encountered this error in the past too. A refresh of the page solved it usually.

1 Like

Hi Blake,
I just tried again this morning re-typing manually in a new calculated field and got the same exact error. My workaround had been to copy and paste the code for {running actual quantity} instead of having it as a field reference and for whatever reason it works this way.

We reached out to the users offline and are implementing a fix for this issue. Thanks for letting us know about this

1 Like