Dataset not visible after creating using CREATE-DATA-SET

Hi all,
We are in the process of migrating QS objects from one account to another. We have described the dataset using describe dataset API, made required changes in the JSON as per AWS documentation. When we run the create dataset command with modified JSON. it runs successfully but dataset is not to be seen under Datasets page (UI). We are able to describe dataset in new account and returns the JSON. Please suggest if anything is missed. Is this related to access issue ?
Note : we are creating the dataset with ADMIN account and checking for dataset using the same account.

Hi @bheemrao.walikar - Can you please run the list data sets in the new account to ensure that data set is available. If the data set is available, you need to give permission to see it to the respective user.

Regards - Sanjeeb

1 Like

@bheemrao.walikar ,

The Admin is probably missing permissions. Run an update-data-set-permissions — AWS CLI 1.27.145 Command Reference and grant the ADMIN access to that dataset.

Kind regards,
Koushik

2 Likes

Spot on @Sanjeeb2022 ! Yes, it gets listed when the list-data-sets is run. We are unable to attach permisions. We are referring to this part of the AWS documentation.

Error : An error occurred (InvalidParameterValueException) when calling the CreateDataSet operation: One or more principals in resource permissions list are not valid QuickSight users

There was mistake in the qs region we had copied. We are able to create and see the dataset on console now. Thank you @Sanjeeb2022 @Koushik_Muthanna for your very prompt and immediate responses ! Highly appreciate it !

2 Likes

Hi @bheemrao.walikar - Glad to hear that the issue is resolved.

Regards - Sanjeeb