Filter settings are not giving "Use Parameter" option

Hi! I’m trying to set some dynamic defaults. I’ve uploaded my dynamic default dataset as a parameter, and I’m trying to connect my market filter. I am not seeing a “user parameters” option in the filter settings. Any thoughts here?

Screen Shot 2022-12-02 at 12.22.50 PM

Change ‘Filter list’ to ‘Custom Filter’