Parameters filtering data for other parameters or setting default

I have 3 parameters, let’s say ID, Name, and Email address. I am using ID as a URL parameter and tag parameter (anonymous embedding). ID, Name, and Email are 1:1:1 let’s say.

As I am passing in a specific ID value, I expect that the associated Name and Email fields are automatically filtered to show the associated Name and Email address for the ID passed through.

When I try to display Name and Email in a title or description, let’s say, the value I get is “All”. I have tried to set the dynamic default value for the parameter and set it to the dataset field but it is still showing “All”. I have done some research on some of the other forum posts and the help text and the only other way it mentions (which I haven’t tried yet) is to create a separate dataset that explicitly lists the ‘default’ value I want to show… and then join that dataset with my main dataset.

I’m thinking this isn’t going to work either. Anyone have any suggestions on what could be done?


It would be helpful to get more context of the use case and what you are trying to achieve from user perspective.

I noted that you are using anonymous embedding so you can pass all 3 values as parameters/session tags and that will restrict the data on your dashboards to those specific values.
Any specific reason you are not passing all 3 values from your parent application to the dashboard?


Hi @pyi, if you create controls of the two parameters and make them relevant to each other, when you make the selection of the first control, the second one would be filtered accordingly. At that time, even if you only have one value left in the second control, QS doesn’t auto-select that value, which means you willl have to select the value to update the parameter. When you do that, your title and discriptions would update accordingly to reflect the parameter value in them.

Actually I created a support case with AWS and showed them what I am trying to do - I got the confirmation it is supposed to work but isn’t working. they are getting back to me after researching more.

Sounds like this is an error and we will work with support to resolve it

Is there a way that you can ping me directly so I can give you my AWS case number?