Mapbox is unable to render

Our mapbox visual stopped working recently without a change to the dataset structure or the visual itself. Is anyone else experiencing this? While troubleshooting, I added a filter and the map is able to display only one row, otherwise it flickers and displays something like “Unable to render. Please refresh the page to try again.” All other visuals on the dashboard are working, and the dataset used in the mapbox visual successfully displays in a table visual.

Hi @Luke_Bearden - First off, by ‘mapbox’ do you mean the ‘filled map’ visual type? Im not able to replicate this with the data sets Im using. I tried a filled map with 50 countries and another with 630 US zip codes and they worked OK. I do remember seeing this on another user’s screen earlier in the week but when they switched to Points on Map (instead of Filled Map) it went away so I didnt really think anything of it.

Nonetheless if this keeps happening, the best course of action would be to open a support case with AWS Support. They are well equipped at handling ‘this seems broken’ types of issues.

Here are the steps to open a support case (Creating support cases and case management - AWS Support). If your company has someone who manages your AWS account, you might not have direct access to AWS Support and will need to raise an internal ticket to your IT team or whomever manages your AWS account. They should be able to open an AWS Support case on your behalf.

1 Like

@Luke_Bearden in addition to answering the questions by Jesse, can you also send us some screenshots of the issue. We will raise a ticket internally to get it checked. Thank you!

1 Like

@Luke_Bearden - We think we’ve got this fixed. Can you try again and let us know if you are still seeing the issue?

Hello, I’ve also been experiencing this issue. Following this thread as the maps still do not work as of time of posting.

It seems fixed for me. Thanks everyone for the help!

1 Like

@02wjenkins Can you try again and let us know if you are still seeing this issue.

Seems to be working again. Thanks a ton, i’ll keep the thread posted if anything changes.

1 Like

@02wjenkins Wonderful! So glad to hear it!

@Kristin unfortunately the issue has returned. rendering for the filled map box visual is inconsistent and fails when using the zoom in/out feature.

@Luke_Bearden We are looking into it. Thank you for reporting.

1 Like

@Luke_Bearden can you tell me more about how the Filled Map is set up? Which field wells are you using and what type of geospatial field are you working with (LatLong, Postal codes, Country, State etc)?

We’re working on a fix but in the meantime can you also try clearing your browser cache to see if it fixes the issue?

Thanks @amitmaka @Rushabh_Vora for working on this!

I’m using a Country geospatial field for the Location field well, and I’m using a Count(Sum) measure in the Color field well.

I’ve emptied the cache, but that doesn’t resolve the issue.

@amitmaka @Rushabh_Vora any updates on this? Should I file a support ticket?